Products on www.Shieldlab.com


Alarm Monitoring

Alarm Monitoring

PPC Ad

Trustpilot Badge >

Women's Self Defense

Women's Self Defense

Members Online

153 Guests, 0 Users

Author Topic: DLS5 Firmware update  (Read 257 times)

rrc_alarm

  • Member
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
DLS5 Firmware update
« on: October 12, 2017, 12:45:14 AM »
Hi again experts!

I'm planning a firmware update on my system tomorrow.

NEO2164 + 3 zone expanders
3 keypads (one LCD)

In just reading through the DLS5 software, I see a note in red:

- Prior to a keypad bundle update, it is highly recommended to install bridge firmware.

Here is the question:

- I see 2 versions of firmware for the panel - bridge and a file without the bridge suffix
- I see 2 versions of firmware for the keypad bundle update - bridge and a file without the bridge suffix

What does it mean to apply bridge firmware first? Does it mean that I apply this sequence:

- Bridge firmware for the panel
- Then followed by the regular firmware for the panel
- Then followed by bridge firmware for the keypads
- Then lastly apply the regular firmware for the keypads

Its a bit confusing. Any input is very appreciated. Thank you so much!
RR

securitydude123

  • Security Pro
  • ***
  • Posts: 65
  • Karma: +1/-0
    • View Profile
Re: DLS5 Firmware update
« Reply #1 on: October 12, 2017, 02:45:04 AM »
Hi RRC,

This is what I had to do when i went through this Crap, Firmware may now be at V1.3, I havent had to program a neo in a month or so, so i dont really remember. But to answer your question yes you want to install the bridge, now for the keypads, do you have the HS2tch? touch screen?? this is the keypad that had massive errors. the firmware upgrade allows you to enter a new section of programming that will allow you to initiate the firmware file you put onto the sd card. Hope this helps....

 
In order to apply the firmware upgrade you need to do the following procedure
 
1.       Perform the touchscreen Bridge firmware upgrade(Using DLS 5)
2.       Perform the touchscreen V1.2 firmware upgrade  (Using DLS 5)
3.       Complete the SD Card Update (Files available off our website www.DSC.com under the technical library)
 
To perform the first two tasks locally you would need to be onsite using the DLS 5 V1.61 and a PC-Link cable. For a guide of the procedure you can refer to the following website: http://dlshelp.dsc.com/index.php?title=Neo_Local_Firmware_Upgrade
 
Files Required:
 

 
SD Card Upgrade Procedure (Files available off our website):
 
Firmware Update
1- [It's recommended) to use a clean SD card,
2- [It's recommended] to make sure the SD-card format is FAT32.
3- unzip the zip file in this folder
4- you will have the following three files
      - hs2tch_update
      - hs2tch_update.sig
      - hs2tchrootfs.ext2
5- copy these three files on the SD card
6- Insert the SD card in the Touch-Screen
7- go to Options | Installer Menu |keypad Programming | Firmware Upgrade
8- follow the on-screen instruction.
 
 

 
"Don't be a prisoner of your own style"

rrc_alarm

  • Member
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: DLS5 Firmware update
« Reply #2 on: October 12, 2017, 12:15:11 PM »
Wow securitydude123, that is an instruction manual quality response! Thank you so much.
I will give this a try and revert back.

Yes, I do have the HS2TCHP along with 2xHS2LCDs in my system.

It appears that in DLS they have v1.31 of HS2TCHP firmware and a bridge available. I will give that a try along with the keypad bundle update that seems to include the HS2LCDPs.

One question - I'm assuming that for the panel as well just like you mention here, first one must apply the bridge and then the regular.

Thank you.

RRC_ALARM

securitydude123

  • Security Pro
  • ***
  • Posts: 65
  • Karma: +1/-0
    • View Profile
Re: DLS5 Firmware update
« Reply #3 on: October 13, 2017, 12:13:53 PM »
Hey, So you must complete the bridge first, then the keypad update through DLS5, so there will be 2 firmware updates required in that order. Once that is complete there will be a new section of programming to allow the keypad to do firmware upgrades. when you find the firmware packet from dsc that has to go on the SD card you must unzip the package for prep. Make sure there is no other files on it as you dont want to run an exe. that doesnt belong and cause issues. I generally keep a SD Card just for this reason on hand  with only this packet on it.

To answer your question, yes install the bridge, then install the update for the keypad. you do not need anything else. The update for the keypad should be labled the keypad model number with the Firmware version. Total updates will be 3 all together including the sd card upgrade
"Don't be a prisoner of your own style"

rrc_alarm

  • Member
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: DLS5 Firmware update
« Reply #4 on: October 13, 2017, 08:49:45 PM »
Thank you securitydude123.

Just finished all the upgrades today. It took a total of about 2.5 hours!

Just like you said, bridge first then the firmware load for the panel itself.

After that, I did the bridge for the keypad bundle (i.e. non Touch screen), followed by a bundle update for the non LCD keypads (this took a LONG time .. the keypads seem slow with firmware updates and they update one instance at a time).

After that, I did the touch pad bridge followed by the touch pad update itself.

One thing that I did NOT do, was an SD card update - the version on DSC's website for the SD card version of the touchpad is one lower than what is available through DLS .. hence skipped this step (i.e. 1.31 file version 5 in DLS, vs. file version 4 on SD).

I bring up the time thing as anyone budgeting time to do this, should really assume about 30 mins for panel updates, and about 30 mins per keypad.

-RRC_ALARM

securitydude123

  • Security Pro
  • ***
  • Posts: 65
  • Karma: +1/-0
    • View Profile
Re: DLS5 Firmware update
« Reply #5 on: October 18, 2017, 02:31:18 PM »
Hey rrc,

Glad to hear you were able to get it done... Yes its a nightmare for the upgrades. very time consuming! I make sure i ask for current version panel on every order i make now
"Don't be a prisoner of your own style"

 

Powered by EzPortal