Products on www.Shieldlab.com


Alarm Monitoring

Alarm Monitoring

PPC Ad

Trustpilot Badge >

Women's Self Defense

Women's Self Defense

Members Online

113 Guests, 0 Users

Author Topic: DSC PC1832 ver. 4.14 wireless compatibility  (Read 542 times)

jmbinette

  • Member
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
DSC PC1832 ver. 4.14 wireless compatibility
« on: February 11, 2018, 08:26:37 PM »
Hi to all,

I want to add a WT5500 keypad to my system.

Rreading documentation, I see that I need v4.6+
My board reads 4.14 and *8 (code) 900 gives me 0414

My question is : is V4.14 > 4.6 ? (I don't know if 4 means a minor revision or if 14 is really the version)

And if not, is there a way to upgrade my 4.14 to 4.6 using DLS or other software ?

Thanks !

AlarmMike

  • Administrator
  • Security Guru
  • *****
  • Posts: 1441
  • Karma: +5/-0
    • View Profile
Re: DSC PC1832 ver. 4.14 wireless compatibility
« Reply #1 on: February 12, 2018, 12:20:56 AM »
WT5500 is a 2-way wireless device which requires the TR5164 wireless transceiver.  The TR5164 is what requires the v4.6 firmware version.  v4.14 is a v4.1 panel which does not support the TR5164.  v4.6 is the latest version (and I'm guessing the last version DSC will put out for the traditional PowerSeries.  I suspect any upgrades will be to the Neo line instead which I'm sure they want people to shift to).

So if you must use a WT5500, then you'll have to upgrade your control board to a v4.6 and add a TR5164 (removing any PC/RF5132 receiver you might have and re-enroll the ESN's into the TR5164.  Ultimately it would be simpler and cheaper to just drop a PK5500 keypad in instead.

And no, you cannot flash upgrade the control board for traditional PowerSeries.  You have to replace the board.  The newer Power Series Neo can be flashed.  That is the whole idea behind it's new product line, flashing rather than reinstalling new hardware.
1993-1995   Worked for one of the "nationals"  /  1996-Present   Independent dealer
Systems supported:   DSC, Ademco/Honeywell, ITI/GE/Interlogix
-----------------------------
To the world you may be one person, but to one person you are the world.
- Kidney transplant recipient 04/27/2011

jmbinette

  • Member
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: DSC PC1832 ver. 4.14 wireless compatibility
« Reply #2 on: February 12, 2018, 08:05:30 AM »
Thanks Mike,

If I am installing a new system, would you recommend switching to the new NEO ?

So far I have not seen any integration with TL280 as we had with EVL3-4 ... but maybe that's not a reason to wait the the "old" PowerSeries ?

Thanks

DCG 1860

  • Member
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: DSC PC1832 ver. 4.14 wireless compatibility
« Reply #3 on: February 14, 2018, 02:32:11 PM »
Well the NEO is the new flagship panel for DSC but there are some things to consider. The main one is that none of the old devices ( keypads, zone expanders, wireless receivers or contacts ) will work on the new panel. If you have a lot of devices it will be a substantial cost to upgrade. The positive is that the new wireless can overcome most every wireless signal interference. Zones are individually programmed instead of being limited by groups if you have zone expanders . New comms also integrate alarm..com with choices of carries for interactive. The list goes on but it would be a huge investment if you have a lot of devices that would need to be changed out.

 

Powered by EzPortal